Web app and Live Support are not available
Incident Report for Xplenty
Resolved
Web app and live support are currently up and running. The services were inaccessible to many of our users due to the attach on DynDNS.
Posted Oct 21, 2016 - 22:01 UTC
Update
For Email Support please send emails to support@xplenty.com
Posted Oct 21, 2016 - 11:57 UTC
Investigating
We are investigating this issue. We are very sorry for the inconvenience.
Posted Oct 21, 2016 - 11:52 UTC