Elevated Job Status Updates Latency
Incident Report for Xplenty
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 07, 2018 - 18:31 IDT
Investigating
We are currently investigating this issue.
Posted 5 months ago. Jun 07, 2018 - 17:26 IDT