Elevated Platform Latency
Incident Report for Xplenty
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 27, 2018 - 19:46 IDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Jun 27, 2018 - 17:00 IDT
Investigating
We are currently investigating reports of elevated platform latency.

Jobs will take a longer time to run.
Posted 5 months ago. Jun 27, 2018 - 16:42 IDT