Intermittent errors while retrieving data from Google Adwords
Incident Report for Xplenty
Resolved
This incident has been resolved
Posted Feb 26, 2017 - 14:00 UTC
Investigating
We're investigating an issue that's causing intermittent errors while retrieving data from Google Adwords
Posted Feb 26, 2017 - 12:34 UTC