Clusters Stuck on Creating, Jobs Not Running

Incident Report for Xplenty

Resolved

The incident has been resolved. The root cause was an issue with our upstream provider, which prevented clusters and jobs from triggering as expected. We are taking steps to improve our monitoring systems to ensure earlier detection in the future. We sincerely apologize for the inconvenience.
Posted Dec 03, 2025 - 05:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2025 - 05:57 UTC

Investigating

We are currently investigating the issue.
Posted Dec 03, 2025 - 04:18 UTC
This incident affected: Infrastructure (Processing Engine).