Clusters Stuck on Creating

Incident Report for Xplenty

Resolved

The incident has been resolved.
Posted Jul 05, 2025 - 02:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results. We apologize for the inconvenience caused.
Posted Jul 04, 2025 - 22:40 UTC

Investigating

We are currently investigating the issue.
Posted Jul 04, 2025 - 22:32 UTC