Cluster Creation Issue
Incident Report for Xplenty
Resolved
Cluster creation issues on Google Cloud - Western Europe region is now back to normal. The issue has been identified and fixed.
Posted Apr 29, 2019 - 19:58 IDT
Investigating
We are currently investigating a delay in cluster creation on Google Cloud - Western Europe region that some customers are experiencing.
Posted Apr 29, 2019 - 18:13 IDT
This incident affected: Web Application (dashboard.xplenty.com).