Intermittent Errors on AWS Services Due to AWS DNS Errors
Incident Report for Xplenty
Resolved
From AWS status page:

Between 10:30 AM and 6:30 PM PDT, we experienced intermittent errors with resolution of some AWS DNS names. Beginning at 5:16 PM, a very small number of specific DNS names experienced a higher error rate. These issues have been resolved.
Posted Oct 23, 2019 - 08:46 IDT
Monitoring
We are having intermittent job failures related to AWS components such as Redshift, S3, RDS, etc. due to AWS DNS errors. We are monitoring on our end until AWS has fully fixed the issue.

Reference: https://status.aws.amazon.com/
Posted Oct 23, 2019 - 05:37 IDT
This incident affected: Infrastructure (AWS - US East (N. Virginia), AWS - US West (Oregon), AWS - EU (Ireland), AWS - Asia Pacific (Sydney), AWS - Asia Pacific (Tokyo), AWS Route53).