Due to AWS's incident some components are still impacted

Incident Report for Xplenty

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 03:00 UTC

Monitoring

Due to AWS's incident the following components are still impacted, SFTP To Go's audit logs and Cron To Go's processing engine
For more details please see below AWS status-
https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 11:47 UTC
This incident affected: Support (Live Chat) and Infrastructure (AWS - US East (N. Virginia)).