Reverse SSH connectivity issue

Incident Report for Xplenty

Resolved

RCA:

Initial findings: There seems to have been an issue with our upstream provider, which we're working with them to identify why. The above solution resolves the issue.
Posted Jun 19, 2025 - 22:30 UTC

Monitoring

RCA: It looks like an issue one of our upstream providers. Follow the steps shared to resolve the issue.

Detailed RCA will be shared soon.
Posted Jun 19, 2025 - 21:47 UTC

Identified

The issue has been identified, and please find the fix below to resolve the connectivity issue.


Please delete/refresh the entry on your known_hosts file. You can do either of the following:

Delete the specific line on ~/.ssh/known_hosts file which contains virginia-tunnel.xplenty.com. Make sure to save.

Execute ssh-keygen -R "[virginia-tunnel.xplenty.com]:50683" on the tunnel instance
Posted Jun 19, 2025 - 20:51 UTC

Investigating

Hi All,

We are experiencing an issue with our Reverse SSH connections, and the jobs are failing.

Action: Investigating the issue
Posted Jun 19, 2025 - 20:41 UTC
This incident affected: Infrastructure (AWS - US East (N. Virginia)).