Cluster Creation Issue
Incident Report for Xplenty
Resolved
Cluster creation issues on Google Cloud Central US region is now back to normal. The issue has been identified and fixed.
Posted 6 months ago. Apr 25, 2019 - 01:19 IDT
Investigating
We are currently investigating a delay in cluster creation that some customers are experiencing.
Posted 6 months ago. Apr 24, 2019 - 23:22 IDT
This incident affected: Web Application (dashboard.xplenty.com).